Cisco Labs – Redundant and Resilient networks (10) – VRRP – Virtual Router Redundancy Protocol – basic, object tracking


Introduction

During my university studies I was doing a diploma thesis in field of Redundant and reliable networking. The purpose of itwas to create LAB examples for students, so they can test First Hop Redundancy Protocols (FHRP) , Any Transport over MPLS (AToM) and Border Gateway Protocol (BGP) on Cisco platform. These tasks are created to Virtlab (Virtual lab with physical Cisco routers) however configuration is valid and tested on physical Cisco routers as well.

Each task in the series will have its separate post with brief description of the task and schema. Complete task can be downloaded on My Skydrive

ZIP file contains:

  • *.HTML file – complete step by step guide how to perform the task
  • *.PNG – pictures with topology and others
  • *_preconf.txt – file with basic configuration of topology to be able to focus on task goal (IP addresses, interfaces and so on)
  • *_end.txt – file with complete configuration. Once put to the routers, you will get working task
  • *.dia – Topology in free DIA editor
  • *.XML – topology in XML format

To complete the task:

  • Connect your environment accorrding the topology
  • open the file *_preconf.txt from ZIP file with complete task and configure your environment with basic settings so you can start with the task.



VRRP – Object tracking

Title: VRRP – Object tracking

Goal:

  • Configure Virtual Router Redundancy Protocol on 192.168.1.0/24 network segment.
  • PC1 represents group 1, its default gateway address is 192.168.1.1.
  • Set priority so that VRRP group 1 master will be RLB1 router.
  • Turn on VRRP object tracking, debuging and test functionality.

Required time: 120 minutes

Theoretical background:

Links related to this task:

Topology:

VRRP-ObjectTracking

Configuration:

 

1) Basic IP settings

OSPF will be used for routing.

PC1

      pc1:~#ifconfig eth0 192.168.1.20 netmask 255.255.255.0; set IP address for PCx
      pc1:~#route add default gw 192.168.1.1; set default gateway to group 1 virtual router IP address

PC2

      pc2:~#ifconfig eth0 20.0.0.2 netmask 255.0.0.0; set IP address for PCx
      pc2:~#route add default gw 20.0.0.1; set default gateway to IP address of EDGE router

Router RLB1

      RLB1(config)#interface #RLB1:RLB1-SW1#; configure physical interface IP address of VRRP enabled interface
      RLB1(config-if)#ip address 192.168.1.251 255.255.255.0; physical IP address of VRRP interface
      RLB1(config-if)#no shutdown
      
      RLB1(config)#interface #RLB1:EDGE-RLB1#; configure interface facing to the external network
      RLB1(config-if)#ip address 172.16.1.1 255.255.0.0
      RLB1(config-if)#no shutdown
      RLB1(config-if)#exit
      
      RLB1(config)#router ospf 1 ; configure routing protocol for internal and external network
      RLB1(config-router)#network 172.16.1.0 0.0.255.255 area 0
      RLB1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router RLB2

Apply analogical settings for the router RLB2.

      RLB2(config)#interface #RLB2:RLB2-SW1#
      RLB2(config-if)#ip address 192.168.1.252 255.255.255.0
      RLB2(config-if)#no shutdown
      
      RLB2(config)#interface #RLB2:EDGE-RLB2#; configure interface facing to the external network
      RLB2(config-if)#ip address 172.17.1.1 255.255.0.0
      RLB2(config-if)#no shutdown
      RLB2(config-if)#exit
      
      RLB2(config)#router ospf 1
      RLB2(config-router)#network 172.17.1.0 0.0.255.255 area 0
      RLB2(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router EDGE

      EDGE(config)#interface #EDGE:PC2-EDGE# ; this network simulates the Internet
      EDGE(config-if)#ip address 20.0.0.1 255.0.0.0
      EDGE(config-if)#no shutdown
      EDGE(config-if)#exit
      EDGE(config)#interface #EDGE:EDGE-RLB2#
      EDGE(config-if)#ip address 172.17.1.2 255.255.0.0
      EDGE(config-if)#no shutdown
      EDGE(config-if)#exit
      EDGE(config)#interface #EDGE:EDGE-RLB1#
      EDGE(config-if)#ip address 172.16.1.2 255.255.0.0
      EDGE(config-if)#no shutdown
      EDGE(config-if)#exit

2) PC1 -> PC2 connectivity test

Use the following command to test connectivity.

      pc1:~#ping 20.0.0.2; ping command is unsuccessful - no GW could be found

3) VRRP and object tracking settings

Status of line protocol will be tracked on loopback interfaces

Configure object tracking

      RLB1(config)#interface loopback 2; enable interface loopback 2
      RLB1(config-if)#ip address 1.1.1.1 255.255.255.0; set IP address
      RLB1(config-if)#no shutdown; turn the interface on
      RLB1(config-if)#exit
      RLB1(config)#track 2 interface loopback 2 line-protocol; create tracking object 2 to track interface loopback 2 and its line protocol

Router RLB1

      RLB1(config)#interface #RLB1:RLB1-SW1#
      RLB1(config-if)#vrrp 1 ip 192.168.1.1 ; set virtual router address for group 1
      RLB1(config-if)#vrrp 1 track 2 decrement 15; track status of object 2 - defined in step 3) - by VRRP RLB1 and decrease VRRP 1 priority by 15
      RLB1(config-if)#vrrp 1 priority 25 ; configure VRRP priority - higher value means higher priority, RLB1 will be master for group 1 because RLB2 has priority 

20
      RLB1(config-if)#vrrp 1 preempt delay minimum 1; set minimum delay to overthrow router with higher priority one

Router RLB2

      RLB2(config)#interface #RLB2:RLB2-SW1#
      RLB2(config-if)#vrrp 1 ip 192.168.1.1 ; set virtual router address for group 1
      RLB2(config-if)#vrrp 1 priority 20
      RLB2(config-if)#vrrp 1 preempt delay minimum 1; set minimum delay to overthrow router with higher priority one

Function test:

1) test ping from PC1 to PC2

      pc1:~#ping 20.0.0.2; ping command is successful - GW could be found as virtual address 192.168.1.1

2) Display VRRP information

      RLB1# sh VRRP; see result, this router is master for group 1
      RLB1# debug VRRP; debug will show VRRP communication between nodes
     
      RLB2# sh VRRP; see result, this router is backup for group 1

3) Shutdown interface on RLB1 to initiate tracking object to decrease priority of RLB1 router by 15

      RLB1(config)#interface loopback 2
      RLB1(config-if)#shutdown

4) Display VRRP information after priority change

      RLB1# sh VRRP; see result, this router is backup for group 1

5) Turn interface loopback 2 on again on RLB1

After interface is turned on, router become master as it has higher priority.

      RLB1# sh VRRP; see result, this router is master

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s