Cisco Labs – Redundant and Resilient networks (12) – MPLS – AToM – Frame Relay over MPLS


Introduction

During my university studies I was doing a diploma thesis in field of Redundant and reliable networking. The purpose of itwas to create LAB examples for students, so they can test First Hop Redundancy Protocols (FHRP) , Any Transport over MPLS (AToM) and Border Gateway Protocol (BGP) on Cisco platform. These tasks are created to Virtlab (Virtual lab with physical Cisco routers) however configuration is valid and tested on physical Cisco routers as well.

Each task in the series will have its separate post with brief description of the task and schema. Complete task can be downloaded on My Skydrive

ZIP file contains:

  • *.HTML file – complete step by step guide how to perform the task
  • *.PNG – pictures with topology and others
  • *_preconf.txt – file with basic configuration of topology to be able to focus on task goal (IP addresses, interfaces and so on)
  • *_end.txt – file with complete configuration. Once put to the routers, you will get working task
  • *.dia – Topology in free DIA editor
  • *.XML – topology in XML format

To complete the task:

  • Connect your environment accorrding the topology
  • open the file *_preconf.txt from ZIP file with complete task and configure your environment with basic settings so you can start with the task.



MPLS – AToM – Frame Relay over MPLS

Title: MPLS – AToM – Frame Relay over MPLS

Goal:

  • Configure MPLS-based core IP network.
  • Configure Any Transport over MPLS technology to forward Frame Relay traffic for DLCI 100 through MPLS core.

Required time: 120 minutes

Theoretical background:

Links related to this task:

Topology:

MPLS-AToM-FrameRelay

Configuration:

 

1) Check pre-configured settings

Before starting configuration of MPLS you should check pre-configured settings. First use ping command to test connectivity between PE1 and PE3 routers. Also

check OSPF if networks are propagated correctly.

 

2) MPLS core configuration

In this part of configuration you will configure basic MPLS functionality.

Router PE1

      PE1(config)#ip cef; enable CEF, prerequisite for MPLS
      PE1(config)#interface #PE1:PE1-P#
      PE1(config-if)#mpls ip; enable MPLS on the interface #PE1:PE1-P#  
      PE1(config)#interface loopback 2; create loopback interface
      PE1(config-if)#ip address 20.0.0.1 255.255.255.255; set IP address on loopback interface
      PE1(config-if)#no shutdown
      PE1(config)#mpls label protocol ldp; MPLS will use LDP as label distribution protocol
      PE1(config)#mpls ldp router-id loopback 2 force; force loopback IP address to be router ID
      PE1(config)#router ospf 1
      PE1(config-router)#network 20.0.0.1 0.0.0.0 area 0; set OSPF to propagate loopback address

Router P

Set P and PE3 routers similarly.

      P(config)#ip cef
      P(config)#interface #P:P-PE3#
      P(config-if)#mpls ip
      P(config)#interface #P:PE1-P#
      P(config-if)#mpls ip
      P(config)#interface loopback 2
      P(config-if)#ip address 30.0.0.1 255.255.255.255
      P(config-if)#no shutdown
      P(config)#mpls label protocol ldp
      P(config)#mpls ldp router-id loopback 2 force
      P(config)#router ospf 1
      P(config-router)#network 30.0.0.1 0.0.0.0 area 0

Router PE3

      PE3(config)#ip cef
      PE3(config)#interface #PE3:P-PE3#
      PE3(config-if)#mpls ip
      PE3(config)#interface loopback 2
      PE3(config-if)#ip address 40.0.0.1 255.255.255.255
      PE3(config-if)#no shutdown
      PE3(config)#mpls label protocol ldp
      PE3(config)#mpls ldp router-id loopback 2 force
      PE3(config)#router ospf 1
      PE3(config-router)#network 40.0.0.1 0.0.0.0 area 0

3) MPLS core function test

Use following commands on core routers PE1, P, PE3 and check results

      Pxx#show mpls ldp binding; display LDP bindings on the router
      Pxx#show mpls ldp discovery; show discovered MPLS enabled peering routers
      Pxx#show mpls ldp neighbor; show peering neighbors
      Pxx#show mpls forwarding-table; display forwarding table with local and remote labels. 

4) AToM configuration – provider side

Router PE1

      PE1(config)#frame-relay switching; enable Frame Relay switching globally on customer edge router PE1
      PE1(config)#interface #PE1:CE1-PE1#
      PE1(config-if)#encapsulation frame-relay; encapsulate traffic by Frame Relay
      PE1(config-if)#frame-relay intf-type DCE; set interface to DCE
      PE1(config-if)#no shutdown
      NEW IOS:
      PE1(config)#connect FRoMPLS #PE1:CE1-PE1# 100 l2transport; define VC 100 which will be used to transport FR traffic over MPLS 
      OLDER IOS:
      PE1(config-fr-pw-switching)#mpls l2transport route 40.0.0.1 100; define VC 100 which will be used to transport FR traffic over MPLS 

VC on MPLS is unidirectional. To configure l2 transport tunnel we need to configure VC 100 on both provider edge routers (PE1, PE3).

Router P

Router P needs to have only basic MPLS configured.

Router PE3

      PE3(config)#frame-relay switching; enable Frame Relay switching globally on customer edge router PE3
      PE3(config)#interface #PE3:PE3-CE2#
      PE3(config-if)#encapsulation frame-relay; encapsulate traffic by Frame Relay
      PE3(config-if)#frame-relay intf-type DCE; set interface to DCE
      PE3(config-if)#no shutdown
      PE3(config-if)#clockrate 64000;clock rate setting for serial interface
      PE3(config-if)#connect FRoMPLS #PE3:PE3-CE2# 100 l2transport; frame relay traffic will be passed from interface #PE3:PE3-CE2# through l2tunnel
      PE3(config-fr-pw-switching)#mpls l2transport route 20.0.0.1 100; matching configuration to PE1

5) AToM configuration – customer side

Customer`s side routers CE1,CE2 must be configured, that interfaces facing MPLS core network must have the same DLCI as we configured to be forwarded on provider`s

side.

Router CE1

      CE1(config)#interface #CE1:CE1-PE1#
      CE1(config-if)#encapsulation frame-relay; set interface as Frame Relay enabled
      CE1(config-if)#frame-relay intf-type dte
      CE1(config-if)#no shutdown
      CE1(config-if)#interface #CE1:CE1-PE1#.1 point-to-point; DLCI 100 will be point-to-point FR circuit
      CE1(config-subif)#ip address 100.0.0.1 255.255.255.0; IP address from the same subnet as on CE2 router
      CE1(config-subif)#frame-relay interface-dlci 100

Router CE2

      CE2(config)#interface #CE2:PE3-CE2#
      CE2(config-if)#encapsulation frame-relay; set interface as Frame Relay enabled
      CE2(config-if)#frame-relay intf-type dte
      CE2(config-if)#no shutdown
      CE2(config-if)#interface #CE2:PE3-CE2#.1 point-to-point; DLCI 100 will be point-to-point FR circuit
      CE2(config-subif)#ip address 100.0.0.2 255.255.255.0; IP address from the same subnet as on CE1 router
      CE2(config-subif)#frame-relay interface-dlci 100

Function test:

1) test MPLS functionality using ping

      PE1# ping mpls ipv4 40.0.0.1; ping command for MPLS

2) Display MPLS related information

Verify the status of virtual circuits on the routers PE1 and PE3. Notice amount of data sent through those circuits. Check VC details.

      Rx# sh mpls l2transport vc detail

3) Test connectivity

Test connectivity between CE1 and CE2 routers.

      CE1# ping 100.0.0.2
      CE1# traceroute 100.0.0.2; there is no hop between customer's IP addresses. The MPLS core acts as single frame relay virtual circuit.

4) show Frame Relay statistics

Run following commands on CE1 or CE2.

      CE1# sh frame-relay map; display active DLCIs and related interfaces 
      CE1# sh frame-relay pvc; display detail statistics of active DLCIs

5) debug MPLS AToM events

Run following commands on the PE1 or PE3.

      PE1# debug mpls l2transport vc event; display debug information related to l2transport tunnel in MPLS core network 

Then go to PE1 console and shut interface facing to CE1 router #PE1:CE1-PE1# down. This will cause the VC 100 to break.

    PE3#
    *Nov 17 00:00:17.047: AToM MGR [20.0.0.1, 100]: Remote end down, vc is down
    *Nov 17 00:00:17.055: AToM MGR [20.0.0.1, 100]: Unprovision and deallocate SSM segment

Turn on the interface again.

Then go to P console and shut some interface down. This will cause the VC 100 to break.

    PE3#
    *Nov 17 00:05:39.815: %LDP-5-NBRCHG: LDP Neighbor 20.0.0.1:0 (2) is DOWN (Discovery Hello Hold Timer expired)
    *Nov 17 00:05:39.823: AToM MGR [20.0.0.1, 100]: Remote end down, vc is down

Optional:

Configure another subinterfaces on the routers PE1,PE3,CE1,CE2 to support more DLCIs to be routed through MPLS core using AToM technology. Follow steps 4) and 5)

from Configuration part.

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s