Cisco Labs – Redundant and Resilient networks (3) – HSRP – Host Standby Router Protocol – basic


Introduction

During my university studies I was doing a diploma thesis in field of Redundant and reliable networking. The purpose of itwas to create LAB examples for students, so they can test First Hop Redundancy Protocols (FHRP) , Any Transport over MPLS (AToM) and Border Gateway Protocol (BGP) on Cisco platform. These tasks are created to Virtlab (Virtual lab with physical Cisco routers) however configuration is valid and tested on physical Cisco routers as well.

Each task in the series will have its separate post with brief description of the task and schema. Complete task can be downloaded on My Skydrive

ZIP file contains:

  • *.HTML file – complete step by step guide how to perform the task
  • *.PNG – pictures with topology and others
  • *_preconf.txt – file with basic configuration of topology to be able to focus on task goal (IP addresses, interfaces and so on)
  • *_end.txt – file with complete configuration. Once put to the routers, you will get working task
  • *.dia – Topology in free DIA editor
  • *.XML – topology in XML format

To complete the task:

  • Connect your environment accorrding the topology
  • open the file *_preconf.txt from ZIP file with complete task and configure your environment with basic settings so you can start with the task.



HSRP – Basic

Title: HSRP – Basic

Goal:

  • Configure Hot Standby Router Protocol on 192.168.1.0/24 network segment so that default gateway 192.168.1.1 will be fault tolerant against single router failure.
  • Configure interface status tracking for HSRP protocol and test functionality.

Required time: 120 minutes

Theoretical background:

Links related to this task:

Topology:

HSRP-Basic

Configuration:

 

1) Basic IP settings

PC1

      pc1:~#ifconfig eth0 192.168.1.20 netmask 255.255.255.0; set IP address for PCx
      pc1:~#route add default gw 192.168.1.1; set default gateway to HSRP virtual IP address

PC2

      pc2:~#ifconfig eth0 20.0.0.2 netmask 255.0.0.0; set IP address for PCx
      pc2:~#route add default gw 20.0.0.1; set default gateway to IP address of EDGE router

Router RLB1

      RLB1(config)#interface #RLB1:RLB1-SW1#
      RLB1(config-if)#ip address 192.168.1.253 255.255.255.0; configure physical interface IP address for HSRP-enabled interface
      RLB1(config-if)#no shutdown
      
      RLB1(config)#interface #RLB1:EDGE-RLB1#; configure interface facing to the external network
      RLB1(config-if)#ip address 172.16.1.1 255.255.0.0
      RLB1(config-if)#clockrate 64000
      RLB1(config-if)#no shutdown
      
      RLB1(config)#router ospf 1 ; configure routing protocol for internal and external network
      RLB1(config-router)#network 172.16.1.0 0.0.255.255 area 0
      RLB1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router RLB2

Apply similar settings on the router RLB2.

      RLB2(config)#interface #RLB2:RLB2-SW1#
      RLB2(config-if)#ip address 192.168.1.254 255.255.255.0
      RLB2(config-if)#no ip redirects
      RLB2(config-if)#no shutdown
      
      RLB2(config)#interface #RLB2:EDGE-RLB2#
      RLB2(config-if)#ip address 172.17.1.1 255.255.0.0
      RLB2(config-if)#clockrate 64000
      RLB2(config-if)#no shutdown
      
      RLB2(config)#router ospf 1
      RLB2(config-router)#network 172.17.1.0 0.0.255.255 area 0
      RLB2(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router EDGE

      EDGE(config)#interface #EDGE:PC2-EDGE# ; this network simulates the Internet
      EDGE(config-if)#ip address 20.0.0.1 255.0.0.0 
      EDGE(config-if)#no shutdown
      
      EDGE(config)#interface #EDGE:EDGE-RLB2#
      EDGE(config-if)#ip address 172.17.1.2 255.255.0.0
      EDGE(config-if)#clockrate 64000
      EDGE(config-if)#no shutdown
      
      EDGE(config)#interface #EDGE:EDGE-RLB1#
      EDGE(config-if)#ip address 172.16.1.2 255.255.0.0
      EDGE(config-if)#clockrate 64000
      EDGE(config-if)#no shutdown
      
      EDGE(config)#router ospf 1 ; configure routing protocol 
      EDGE(config-router)#network 172.16.1.0 0.0.255.255 area 0
      EDGE(config-router)#network 172.17.1.0 0.0.255.255 area 0
      EDGE(config-router)#network 20.0.0.0 0.0.0.255 area 0

2) PC1 -> PC2 connectivity test

Use following command to test connectivity.

      pc1:~#ping 20.0.0.2; ping command is unsuccessful

3) HSRP settings

Router RLB1

      RLB1(config)#interface #RLB1:RLB1-SW1#
      RLB1(config-if)#standby 1 ip 192.168.1.1 ; set HSRP virtual gateway IP address for standby group 1
      RLB1(config-if)#standby 1 preempt delay minimum 1; set minimum delay to initialize overthrow router with higher priority one
      RLB1(config-if)#standby 1 priority 100 ; configure standby priority - higher value means higher priority, this will be active router because other has priority 50
      RLB1(config-if)#standby 1 track #RLB1:EDGE-RLB1#; track status of selected interface to change active/standby router in case of failure 

Router RLB2

      RLB2(config)#interface #RLB2:RLB2-SW1# ; enter physical internal interface configuration mode
      RLB2(config-if)#standby 1 ip 192.168.1.1 ; set HSRP virtual gateway IP address for standby group 1
      RLB2(config-if)#standby 1 preempt delay minimum 1
      RLB2(config-if)#standby 1 priority 50 ; lower number means lower priority - this router will be hot standby router
      RLB2(config-if)#standby 1 track #RLB2:EDGE-RLB2#; track status of selected interface to change active/standby router in case of failure 

Function test:

1) test ping from PC1 to PC2

      pc1:~#ping 20.0.0.2; ping command is successful - GW could be found as virtual address 192.168.1.1

2) Display standby information

      RLB1# sh standby; see result, this router is active
     
      RLB2# sh standby; see result, this router is standby

3) Change priority for RLB2

Once priority is changed from lower value (50 < 100) to higher value 150, active router will be switched from RLB1 to RLB2.

      RLB2(config)#interface #RLB2:RLB2-SW1#
      RLB2(config-if)#standby 1 priority 150

4) Display standby information after priority change

      RLB1# sh standby; see result, this router is stabdby
     
      RLB2# sh standby; see result, this router is active

5) Turn off internal ethernet interface on RLB2 (active) to failover to standby router RLB1

      RLB2(config)#interface #RLB2:RLB2-SW1#
      RLB2(config-if)#shutdown

6) See result on RLB1

      RLB1# sh standby; see result, this router is active

7) Turn interface back on RLB2

After interface is turned on, router become active since it has higher standby priority.

      RLB2# sh standby; see result, this router is standby

8) Turn of interface #SW1:RLB1-SW1# on SW1

After interface is turned off, router RLB1 will change its status to standby.

      RLB2# sh standby; see result, this router is active

Optional:

Use http://www.ciscoblog.com/docstore/haiphsrp.pdf to configure and test more HSRP features

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s