Cisco Labs – Redundant and Resilient networks (9) – VRRP – Virtual Router Redundancy Protocol – basic


Introduction

During my university studies I was doing a diploma thesis in field of Redundant and reliable networking. The purpose of itwas to create LAB examples for students, so they can test First Hop Redundancy Protocols (FHRP) , Any Transport over MPLS (AToM) and Border Gateway Protocol (BGP) on Cisco platform. These tasks are created to Virtlab (Virtual lab with physical Cisco routers) however configuration is valid and tested on physical Cisco routers as well.

Each task in the series will have its separate post with brief description of the task and schema. Complete task can be downloaded on My Skydrive

ZIP file contains:

  • *.HTML file – complete step by step guide how to perform the task
  • *.PNG – pictures with topology and others
  • *_preconf.txt – file with basic configuration of topology to be able to focus on task goal (IP addresses, interfaces and so on)
  • *_end.txt – file with complete configuration. Once put to the routers, you will get working task
  • *.dia – Topology in free DIA editor
  • *.XML – topology in XML format

To complete the task:

  • Connect your environment accorrding the topology
  • open the file *_preconf.txt from ZIP file with complete task and configure your environment with basic settings so you can start with the task.



VRRP – Basic

Title: VRRP – Basic

Goal:

  • Configure Virtual Router Redundancy Protocol on 192.168.1.0/24 network segment. One group of hosts resides on network segment.
  • PC1 represents group 1, its default gateway address is 192.168.1.1.
  • Set VRRP group for each group of hosts, use priority setting so that VRRP group 1 master will be RLB1 router and VRRP group 2 master will be RLB2 router(optional).
  • Turn on VRRP debuging and test functionality.
  • As optional task configure PC3 represents group 2 and its default gateway address is 192.168.1.2.

Required time: 120 minutes

Theoretical background:

Links related to this task:

Topology:

VRRP-Basic

Configuration:

 

1) Basic IP settings

OSPF will be used for routing.

PC1

      pc1:~#ifconfig eth0 192.168.1.20 netmask 255.255.255.0; set IP address for PCx
      pc1:~#route add default gw 192.168.1.1; set default gateway to group 1 virtual router IP address

PC2

      pc2:~#ifconfig eth0 20.0.0.2 netmask 255.0.0.0; set IP address for PCx
      pc2:~#route add default gw 20.0.0.1; set default gateway to IP address of EDGE router

PC3

      pc3:~#ifconfig eth0 192.168.1.120 netmask 255.255.255.0; set IP address for PCx
      pc3:~#route add default gw 192.168.1.2; set default gateway to group 2 virtual router IP address

Router RLB1

      RLB1(config)#interface #RLB1:RLB1-SW1#; configure physical interface IP address of VRRP enabled interface
      RLB1(config-if)#ip address 192.168.1.251 255.255.255.0; physical IP address of VRRP interface
      RLB1(config-if)#no shutdown
      
      RLB1(config)#interface #RLB1:EDGE-RLB1#; configure interface facing to the external network
      RLB1(config-if)#ip address 172.16.1.1 255.255.0.0
      RLB1(config-if)#no shutdown
      RLB1(config-if)#exit
      
      RLB1(config)#router ospf 1 ; configure routing protocol for internal and external network
      RLB1(config-router)#network 172.16.1.0 0.0.255.255 area 0
      RLB1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router RLB2

Apply analogical settings for the router RLB2.

      RLB2(config)#interface #RLB2:RLB2-SW1#
      RLB2(config-if)#ip address 192.168.1.252 255.255.255.0
      RLB2(config-if)#no shutdown
      
      RLB2(config)#interface #RLB2:EDGE-RLB2#; configure interface facing to the external network
      RLB2(config-if)#ip address 172.17.1.1 255.255.0.0
      RLB2(config-if)#no shutdown
      RLB2(config-if)#exit
      
      RLB2(config)#router ospf 1
      RLB2(config-router)#network 172.17.1.0 0.0.255.255 area 0
      RLB2(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router EDGE

      EDGE(config)#interface #EDGE:PC2-EDGE# ; this network simulates the Internet
      EDGE(config-if)#ip address 20.0.0.1 255.0.0.0
      EDGE(config-if)#no shutdown
      EDGE(config-if)#exit
      EDGE(config)#interface #EDGE:EDGE-RLB2#
      EDGE(config-if)#ip address 172.17.1.2 255.255.0.0
      EDGE(config-if)#no shutdown
      EDGE(config-if)#exit
      EDGE(config)#interface #EDGE:EDGE-RLB1#
      EDGE(config-if)#ip address 172.16.1.2 255.255.0.0
      EDGE(config-if)#no shutdown
      EDGE(config-if)#exit

2) PC1,PC3 -> PC2 connectivity test

Use following command to test connectivity.

      pc1:~#ping 20.0.0.2; ping command is unsuccessful - no GW could be found
      pc3:~#ping 20.0.0.2; ping command is unsuccessful - no GW could be found

3) VRRP settings

Router RLB1

      RLB1(config)#interface #RLB1:RLB1-SW1# ; enter physical internal interface configuration mode
      RLB1(config-if)#vrrp 1 ip 192.168.1.1 ; set virtual router address for group 1
      RLB1(config-if)#vrrp 1 priority 10 ; configure VRRP priority - higher value means higher priority, RLB2 will be master for group 1 because RLB2 has priority 

20
      RLB1(config-if)#vrrp 1 preempt delay minimum 1; set minimum delay to overthrow router with higher priority one
      
      RLB1(config)#interface #RLB1:RLB1-SW1# ; enter physical internal interface configuration mode
      RLB1(config-if)#vrrp 2 ip 192.168.1.2 ; set virtual router address for group 2
      RLB1(config-if)#vrrp 2 priority 20 ; configure VRRP priority - higher value means higher priority, RLB1 will be master for group 2 because RLB1 has priority 

20
      RLB1(config-if)#vrrp 2 preempt delay minimum 1; set minimum delay to overthrow router with higher priority one

Router RLB2

      RLB2(config)#interface #RLB2:RLB2-SW1# ; enter physical internal interface configuration mode
      RLB2(config-if)#vrrp 1 ip 192.168.1.1 ; set virtual router address for group 1
      RLB2(config-if)#vrrp 1 priority 20
      RLB2(config-if)#vrrp 1 preempt delay minimum 1; set minimum delay to overthrow router with higher priority one
      
      
      RLB2(config)#interface #RLB2:RLB2-SW1# ; enter physical internal interface configuration mode
      RLB2(config-if)#vrrp 2 ip 192.168.1.2 ; set virtual router address for group 2
      RLB2(config-if)#vrrp 2 priority 10
      RLB2(config-if)#vrrp 2 preempt delay minimum 1; set minimum delay to overthrow router with higher priority one

Function test:

1) test ping from PC1,PC3 to PC2

      pc1:~#ping 20.0.0.2; ping command is successful - GW could be found as virtual address 192.168.1.1
      pc3:~#ping 20.0.0.2; ping command is successful - GW could be found as virtual address 192.168.1.2

2) Display VRRP information

      RLB1# sh VRRP; see result, this router is backup for group 1 and master for group 2
      RLB1# debug VRRP; debug will show VRRP communication between nodes
     
      RLB2# sh VRRP; see result, this router is master for group 1 and backup for group 2

3) Change priority for RLB2

      RLB2(config)#interface #RLB2:RLB2-SW1#
      RLB2(config-if)#vrrp 1 priority 5

4) Display VRRP information after priority change

      RLB1# sh VRRP
     
      RLB2# sh VRRP

5) Turn off internal ethernet interface on RLB1 (master) to failover to backup router RLB2

      RLB1(config)#interface #RLB1:RLB1-SW1#
      RLB1(config-if)#shutdown

6) See result on RLB2

      RLB2# sh VRRP; see result, this router is master for both groups

7) Turn interface back on RLB2

After interface is turned on, router become master since it has higher priority for both groups.

      RLB2# sh VRRP; see result, this router is master for group 1 and backup for group 2 again

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s