Exchange 2013 – Unable to mount database (Event ID: 226) and the licensing

22.01.2013

I noticed following error message in EMS when I wanted to mounted databases (concretely DB05).

Couldn't mount the database that you specified. Specified database: DB05; Error code: An Active Manager operation
failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionTooManyMountedDatabases:
Unable to mount database. (hr=0x8004060e, ec=-2147219954)

I had configuration below:

PS C:\> Get-MailboxDatabase -Server $env:COMPUTERNAME | ft name
Name
----
TMPDB9918
DB01
DB02
DB03
DB04
DB05

I mounted all databases except of DB05 so a Exchange Server Licensing issue? (because the Standard edition allows up to five mailbox databases, while the Enterprise edition allows up to 100. Thus, you should request the enterprise edition if your organization is fairly large.)? But I had done related licensing through a script:

$ProductID = "ABCD-1234-ABCD-1234-ABCD"
Get-ExchangeServer | Set-ExchangeServer -ProductKey $ProductID | Out-Null
# Information Store service restart because of entering Product Key
$exchsrv = Get-ExchangeServer | sort -Descending -p name | select name
$exchsrv | ForEach-Object {Invoke-Command -ComputerName $_.name -ScriptBlock {restart-service "Microsoft Exchange Information Store"}}

Get-ExchangeServer | ft Edition,IsExchangeTrialEdition -a
Edition IsExchangeTrialEdition
------- ----------------------
Enterprise False
Enterprise False
Enterprise False
Enterprise False

Application log confirmed my assumption:

Log Name: Application
Source: ExchangeStoreDB
Event ID: 226
Task Category: Database recovery
Level: Error
Keywords: Classic
Description:
At '1/22/2013 8:03:22 PM' the copy of database 'DB05' on this server didn't mount because the number of mailbox database copies on this server exceeds the supported limit. The error returned by failover was "There is only one copy of this mailbox database (DB05). Automatic recovery is not available.".

Well I tried to restart Microsoft Exchange Information Store service again and I got:

PS C:\> Restart-Service "Microsoft Exchange Information Store"
Restart-Service : Service 'Microsoft Exchange Information Store (MSExchangeIS)' cannot be stopped due to the following
error: Cannot open MSExchangeIS service on computer '.'.

It seemed like my script could not passed before (no attention maybe). The error above is caused by “insufficient” permission. Run Exchange Management Shell as Administrator solved it. I could restart Microsoft Exchange Information Store services and after that and mounted the database successfully.

Advertisements